
Centered Item at Top of Page. This uses the Float Setting “Top of Page” rather than “Here if Possible”.
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Abstract

This document provides some tips and examples for people who have a basic understanding of LYX (a real
abstract should be longer).
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1 Setup

1.1 LYX Version
If you will have multiple people working in LYX, make sure you are all using the same version. You can accomplish
this and save time on the slow download by putting the installer on a flash drive.

1.2 Page Margins
Page margins should be set right away so that your previews will be accurate. LYX defaults to very large page
margins, which you can change under Document > Settings > Margins. This document uses 2cm for top, bottom,
inner, and outer. Changing margins may affect how figures appear on the page, which is especially important for
your title page.

1.3 Page Style
The header and footer in this document use the page style “fancy” found under Document > Settings > Page Layout
.

1.4 LATEX Preamble
LATEX code that needs to appear at the start of your document can be placed in Document > Settings > LATEX
Preamble . (You don’t need to worry about that unless you read “put this in the preamble.”)

1.5 File Locations
If you insert a file (such as an image), the information is not stored in the LYX document. You need to keep the
file in the same relative location with the LYX file for it to load properly.

1.6 Exporting to PDF

You can preview a PDF version with the view icon . File > Export > pdf (pdflatex) will export to a pdf with
the same name and directory as your LYX file.

2 Insertions

2.1 Copy/Paste
In order to avoid newline characters being discarded, use Edit > Paste Special > Plain Text, or the shortcut Ctrl
+ Shift + V.

c l a s s He l lo de f i n i t i a l i z e @hi = "He l lo ! " end at t r_acce s so r : h i end

Figure 1: Infuriating Ctrl+V paste

c l a s s He l lo
de f i n i t i a l i z e

@hi = "He l lo ! "
end
at t r_acce s so r : h i

end

Figure 2: Correct Ctrl+Shift+V paste
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2.2 Graphics

Graphics can be inserted using Insert > Graphics or clicking on .

2.2.1 Size

You will probably need to set the size for every image you insert. In most cases the easiest thing is to check “Set
width:”, change cm to Column Width %, and set a value less than 100. You can also check “Scale Graphics” to set
a percentage of the original size. If you need to change it later you can access an image’s settings by clicking on it.

2.2.2 Captions

Using Insert > Float > Figure Wrap Float or Insert > Float > Figure will let you caption your image. See the
subsection on Floats.

2.2.3 Centering

You can center an image (or anything) by highlighting it, clicking the paragraph icon , and selecting ’Center’.

2.3 Code
You can insert code that you wrote using Insert > Program Listing. This will escape any special characters and
slightly change the font. See the subsection on Copy/Paste.

3 Equations & Data

3.1 Equations

Inline equations can be inserted by clicking the insert math icon . This will open a toolbar at the bottom that
allows you to insert various math symbols. If you have a lot of inline equations you can have the math toolbar

always on by clicking the toggle math toolbar icon . Making equations can be a little difficult at first. Note that

you cannot add extra space with the spacebar, but if you really need extra space the ’math spacings’ icon will
put space in for you.

To offset an equation from your text, use Insert > Math > Display Formula . You can caption your formula by
wrapping it in a float (if you forget to make the float first, you can highlight the equation box and then insert the
float). See the subsection on floats.

cosh(x) =

∞∑
n=0

x2n

(2n)!

Figure 3: Taylor Series Expression of Hyperbolic Cosine

3.2 Tables
3.2.1 Standard Tables

Tables can be made with Insert > Table or the table icon . When editing a table, a toolbar will appear at the
bottom that allows you to add, remove, or move rows and columns. By default, the first row is offset as a header.

A table can be captioned by putting it inside a table float (Insert > Float > Table). It can be centered by

highlighting it, clicking the paragraph icon and selecting center.
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Character ASCII Code HTML Description
! 33 &#33; Exclamation Mark

160 &nbsp; Non-breaking Space

Table 1: Special Characters in ASCII and HTML

3.2.2 Side by Side Tables

Two tables can be put side by writing LATEX code that follows the format below (click the LATEX icon ).
The |c|c| creates two columns with vertical borders. The first empty hline offsets the first row as the column
names, and the last empty hline closes the last row. See http://tex.stackexchange.com/questions/2832/
how-can-i-have-two-tables-side-by-side and http://www.andy-roberts.net/writing/latex/tables .

\ begin { tab l e } [ ht ]
\ begin {minipage } [ b ] { 0 . 4 5\ l i n ew id th }\ c en t e r i ng
\ begin { tabu la r }{ | c | c | c | }
\ h l i n e Let t e r&Number\#&Word\\
\ h l i n e
\ h l i n e B&2&Box\\
\ h l i n e N&14&Note\\
\ h l i n e V&22&Vehic l e \\
\ h l i n e
\end{ tabu la r }
\ capt ion {The Le f t Table}
\end{minipage}
\hspace {0 .5cm}
\begin {minipage } [ b ] { 0 . 4 5\ l i n ew id th } \ c en t e r i ng
\ begin { tabu la r }{ | c | c | }
\ h l i n e Let t e r&Number\\
\ h l i n e
\ h l i n e A&1\\
\ h l i n e C&3\\
\ h l i n e
\end{ tabu la r }
\ capt ion {The Right Table}
\end{minipage}
\end{ tab l e }

Figure 4: LATEX for Side by Side Tables

Letter Number# Word
B 2 Box
N 14 Note
V 22 Vehicle

Table 2: The Left Table

Letter Number
A 1
C 3

Table 3: The Right Table

3.3 Lists
3.3.1 Default Lists

Ordered lists are made using the “Enumerate” type and unordered lists with the “Itemize” type. Tab and Shift-Tab
moves between levels.

1. Number
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(a) Letter
i. Roman Numeral

• Bullet Point

– Dash
∗ Asterisk

3.3.2 Custom Lists

To make a list with letters instead of numbers, you will need to put this in the preamble:

\ usepackage {enumerate}

Then you will have to write the list in TEX. Click the TEX icon to insert LATEX code. Then create the list
as below:

\ begin {enumerate } [ a . ]
\ item{My f i r s t item}
\ item{My second item}

\begin {enumerate } [ i ) ]
\ item{Subitem 1}
\ item{Subitem 2}

\end{enumerate}
\ item{My th i rd item}
\end{enumerate}

Figure 5: LATEX for Customized List

a. My first item

b. My second item

i) Subitem 1
ii) Subitem 2

c. My third item

See http://tug.ctan.org/tex-archive/macros/latex/required/tools/enumerate.pdf .

3.3.3 Multiple Line List Item

To put multiple lines in one list item, use Insert > Box > Frameless.

• This item needs more than
one line to look right.

• This item fits on one line.

4 Formatting

4.1 Floats
Floats can be used to offset and caption images, tables, equations, etc. To avoid unpredictable placement go to
Document > Settings > Float Placement and select “Here if Possible”. Note that this doesn’t always work; for
example, the float at the top of the first page needed to have the setting “Top of Page”. The settings for an
individual float can be changed by right-clicking the grey box and selecting Settings. If you use a wrap float, LYX

will try to wrap the text around your float, but this might not look good. Use preview to make sure your float
is placed correctly.
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4.2 Centering

Items can be centered by highlighting them, clicking the paragraph icon , and selecting “Center”.

4.3 Font

If a particular piece of text needs to be bold, italic, etc., you can highlight it and click the font icon . This is a
workaround for special cases. LYX does not offer word processor-style formatting.

4.4 URLs and Hyperlinks
A plain URL won’t wrap to the next line, so to prevent running off the page, select Insert > URL to make a link
like this: http://www.ctan.org. If you’re publishing your document online you can make an active hyperlink by

clicking or going to Insert > Hyperlink.

4.5 Templates
If you’re making a particular style of document, e.g. a resume, there are many templates available online. Some of
them may already be included with your LYX installation (File > New from Template...).

5 Smart Features

5.1 Table of Contents
When you use numbered Sections, Subsections, etc., LYX will automatically generate a Table of Contents for you.
You need to insert it after your title page using Insert > List/TOC > Table of Contents . You’ll also want to offset
it by putting a newpage (Insert > Formatting > New Page) before and after.

5.2 Bibliography
5.2.1 BibTEX Format

Your bibliography entries will need to be stored in a separate .bib file. See the file ’sample.bib’ for an example.
For an overview of the different types of entries see https://www.verbosus.com/bibtex-style-examples.html
Not every category is required for every entry (e.g., a book might not have a series). Preview the bibliography

to make sure it’s printing correctly.

5.2.2 Connecting the Bibliography

After your main content but before your appendix, click Insert > List/TOC > BibTEX Bibliography... . Put a new
page (Insert > Formatting > New Page) before and after.

• Click Add... > Browse... to open your .bib file

• Choose “all cited references” if you only want what you cite to appear, or “all references” if you want every
entry to appear

• You can check “Add bibliography to TOC” but it seems to show up as References whether it is checked or not

5.2.3 Making Citations

After connecting the bibliography, you can make citations [3] with Insert > Citation... . Select all the citations you
want at this particular place and click add [2, 1]. Citations will appear as [1] and multiple citations as [2, 3]. See
the preview of this document. Note that regardless of the numbering in your .bib file, citations will be ordered by
the author’s last name.
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5.3 Header/Footer
5.3.1 Page Layout

To have a header like in this document, Document > Settings > Page Layout > Page style is set to “fancy”.

5.3.2 Preamble

The header is defined in Document > Settings > Preamble. The settings for this document provide a centered title
on every page and Page # of Pages on the right. To add something on the left, another line with [L] could be used.

The second line in this document’s preamble clears the default header and footer.

• The default header and footer for “plain” page layout is a page number at the bottom of every page.

• The default header and footer for “fancy” page layout is a subsection heading at the upper left, section heading
at the upper right, and a page number at the bottom of every page.

If you still want section headings on the upper left, you can follow the format in the second figure. This will give,
for example, “Contents” by the TOC and “2 Euler’s Method” by section 2 Euler’s Method . See the documentation
at https://ctan.org/pkg/fancyhdr for a complete guide.

\ usepackage { l a s tpage }
\ fancyh f {}
\ fancyhead [C] {The Heading o f Every Page}
\ fancyhead [R]{\ thepage \ o f \ page r e f {LastPage }}

Figure 6: The LATEX Preamble for this Document’s Header

\usepackage { l a s tpage }
\ fancyh f {}
\ lhead {\ nouppercase {\ l e f tmark }}
\ fancyhead [C] {The Heading o f Every Page}
\ fancyhead [R]{\ thepage \ o f \ page r e f {LastPage }}

Figure 7: Header that Includes Page Headings
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6 Appendix

6.1 Special Characters
The following characters have a special meaning in LATEX:

# $ & \ % ^ { } _ ~

Figure 8: LATEX Special Characters

They can be entered directly into the main part of your document. However, if they are put in your bibliography,
preamble, or LATEX code insertion without being escaped properly, they will cause an error. This can usually be
solved by putting a \ in front of the character. Three characters are escaped differently:

• \ is written \textbackslash{}

• ^ is written \textasciicircum{}

• ~ is written \textasciitilde{}

If you’re reading this in LyX you can see these escape characters by clicking in the figure above and selecting View
> Code Preview Pane .

6.2 Obtaining LYX
LYX can be downloaded from https://www.lyx.org/Download . The download may take an hour or two.

6.3 License
LYX is released under the GNU General Public License, version 2 or later. The icons used in this document are
from LYX. See https://www.lyx.org/License .


